Unable to run profiling: “Failed to verify x64 COM object registration: Empty path to COM object”
Symptoms:
dotMemory doesn’t start a profiling session with the following message:
Failed to verify x64 COM object registration: Empty path to COM object. Do you want to continue anyway?
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Possible cause:
Unfinished Windows updates
To resolve the issue:
1) Install the latest available Windows updates
2) Reboot your machine
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Possible cause:
The user account that was used to run dotMemory has insufficient rights
To resolve the issue:
1) Run dotMemory with the administrator privileges
2) If this doesn't help, press Ctrl+Alt+Shift+F11 in the profiling configuration window and select one the of the following registry-free modes in "Core registration":
- Registry-free, if the profiled application uses .NET Framework v4.5.1 or later
- Registry-free for x86 or x64, if the profiled application (x86 or x64) uses .NET Framework 4.0
3) Save the settings and run the profiling session
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Possible cause:
dotMemory installation is corrupted
To resolve the issue:
1) Uninstall all ReSharper Ultimate products
2) In the Windows registry, delete HKEY_CURRENT_USER\Software\JetBrains\Profiler if it exists
3) Reboot your machine
4) Install Resharper and related components, running the installation with the administrator privileges
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Possible cause:
The "Warsaw" software (an app from Itau Unibanco SA) blocks profiler DLLs. Most likely, the profiler is blocked by the "G-Buster" process
To resolve the issue:
Stop the G-Buster process or uninstall the Warsaw software
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