Coverage fails with the error: “Failed to verify x64 COM object registration: Empty path to COM object”

Symptoms

dotCover fails to run coverage. All tests in the Unit Test Session window are marked as “Inconclusive: Test not run”. Unit test session execution log shows the error: “Failed to verify x64 COM object registration: Empty path to COM object”.

 

Possible cause

  • Unfinished Windows updates.
  • Profiled process PID conflicts with dotCover PIDs.
  • (Very rare) The user account that was used to run Visual Studio has insufficient rights.

 

Solution

Do the following:

  1. Install the latest available Windows updates (if there are any).
  2. In the Windows registry, delete HKEY_CURRENT_USER\Software\JetBrains\Profiler.
  3. Reboot your machine.

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