Coverage fails with the error: “Failed to verify x64 COM object registration: Empty path to COM object”
Symptoms
dotCover fails to run coverage. All tests in the Unit Test Session window are marked as “Inconclusive: Test not run”. Unit test session execution log shows the error: “Failed to verify x64 COM object registration: Empty path to COM object”.
Possible cause
- Unfinished Windows updates.
- Profiled process PID conflicts with dotCover PIDs.
- (Very rare) The user account that was used to run Visual Studio has insufficient rights.
Solution
- Install the latest available Windows updates (if there are any).
- In the Windows registry, delete HKEY_CURRENT_USER\Software\JetBrains\Profiler.
- Reboot your machine.
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I'm getting exactly this error on a self-hosted Azure DevOps build agent. It's running as 'Network Service', so it would be good to document what additional permissions are required so they can be added. This is for case: The user account that was used to run Visual Studio has insufficient rights
Update: For any future internet travellers, I ended up creating a new AzureBuildAgent user on the self-hosted build machine, adding the new user to a new AzureBuildAgents group and giving the group full control on the build agent '_work' folder. No idea why it solved the error, but it did.