Failed to start profiling: Unable to start profiling

Hi,

I have a quite similar problem with this support discusson :

https://dotnettools-support.jetbrains.com/hc/en-us/community/posts/360000115090-Failed-to-start-dot-trace-profiling-on-Windows-Server-2012-R2

 

We use New Relic but I stopped the service before trying to run dotTrace. New Relic is stopped because I don't see anything on their interface.

As I stopped New Relic, I've restarted IIS. When the website was restarted, I ran then dotTrace. It has worked twice. Five hours later, I became the warning message below when I tried to re-run dotTrace.

What do I need to do ?

I can't restart the website in the daylight because of our traffic (250k session/week).

The idea to use dotTrace was to run (on demand) it as we are facing problem with the website.

1 comment
Comment actions Permalink

Unfortunately, there is no easy way to find out what application is preventing dotTrace from attaching to an app.
You can view a list of all assemblies loaded into the process and try to find suspicious ones.
To do this, please do the following:
- install Process Explorer tool from Microsoft site (https://docs.microsoft.com/en-us/sysinternals/downloads/process-explorer ),
- run it under an account with administrative rights,
- start profiling of the application,
- set focus to the corresponding process in Process Explorer,
- press Ctrl+L (or enable Show Lower Panel option in View menu), then press Ctrl+D for enabling DLLs view, then press Ctrl+A to save information about the process to a file.

If there are no suspicious entries in the list, please share it with me (here or via the "Submit the request" button in the upper right corner) and I'll try to help you further.

0

Please sign in to leave a comment.