Profiling session takes a long time to start

Issue

You experience a long delay (up to tens of seconds) when starting a profiling session. You might also receive the error: "Timeout is exceeded: the elevation request is performing for too long".

Possible cause

To keep things safe, JetBrains ETW Collector Host validates the certificate of the data collector process. It does this by making a Windows API call which checks the certificate online. In some cases, especially on virtual machines with certain network setups, this check can take a long time.

Solution

JetBrains ETW Collector Host can check the certificate locally (using the local Certificate Revocation List) instead of online.
To configure this:

  1. Open the Windows "services.msc" (you can type "services.msc" into your Start menu search bar and press Enter).
  2. Look for "ETW Host Service" in the list and double-click it to open its properties.
  3. Click "Stop" to temporarily stop the service.
  4. In the "Start parameters" box, add "--local_crl".
  5. Click "Start" to start the service with the new parameter.
    By using the local_crl option, the ETW Collector Host will check the certificate against a local list, which can save a lot of time. But remember, using the local list might not be as safe as checking online because it might not be up to date.
0 out of 0 found this helpful

Please sign in to leave a comment.

Have more questions?

Submit a request