Memory snapshot not opening due to "Can't set eof" error

I am trying to debug a .NET multi-threaded application in Visual Studio and profile this .NET test process using DotMemory 2019.3.3. After hitting "Get Snapshot", the memory snapshots dialog shows "Saving the snapshot" and the snapshot never opens. There happens to be a small exclamation mark which on clicking gives the message as follows:-

"The requested operation cannot be performed on a file with a user-mapped section open - Can't set eof [location] - ... "

Also tried setting the system environment variable 'JETBRAINS_PROFILER_CORE_USEGHSTWND' as per the post below but the same error keeps showing up.

https://dotnettools-support.jetbrains.com/hc/en-us/articles/360002089660--Can-t-set-eof-error-occurs-while-getting-a-snapshot-in-dotMemory-2018-3 

Spend hours digging up this issue and work-around but no luck. Any help would be really appreciated.

1 comment
Comment actions Permalink

Hi,

Does this issue still occur?

One of the possible reasons is that some software on your PC opens/reads the snapshot files in %TEMP%\jb.*.sst while we are writing them. We asked you to check opened handles in your system when snapshot is saving.

If the issue still persists, please try to scan opened handles in your system while saving the snapshot:

  • Run Process Hacker (https://processhacker.sourceforge.io/) as Administrator to check system and service processes
  • Go to Find Handles or DLLs
  • Search jb..*.sst with Regex option enabled

Probably if no third-party processes is found you should repeat it several times to catch the race condition (if any).

After that please copy-paste the output or take a screenshot. Also please specify the PID of the profile process.

0

Please sign in to leave a comment.