runsettings exclude not working

Answered

Hey

I'm using win10, vs2019 and Resharper 2019.2.3.

When running the unit tests, using the defined .runsettings, which I've checked along with the source code, the exclusion part isn't used/working by dotCover.
If I run the built in vs2019 test, it is working. The, e.g. unit tests themselves isn't included in the result. But using the dotCover, they are. I have selected the runsettings -file in the settings of Unit Tests, but still they show up. Am I missing something..?


Mstest

dotCover

runsettings

<Exclude>
<ModulePath>.*Tests\.dll$</ModulePath>
<ModulePath>.*tests\.dll$</ModulePath>
<ModulePath>.*logger\.dll$</ModulePath>
</Exclude>

Am I missing something..?

 

2 comments
Comment actions Permalink

Hello Johan, VS runsettings file only affects VS' tests, dotCover does not use these exclusions and uses only its own coverage filters. 

0
Comment actions Permalink

Ok, that was news to me. What exactly does the settings in Resharper Options do then?

 

Despite the file has the information, it isn't applied within dotCover? 

So, what you need is to export this as a file as well (dotCover filters) and add it to the repository. So it could be used by my colleagues?

0

Please sign in to leave a comment.