Export To Detailed XML has file paths and names all in lowercase

Completed

When exporting code coverage via "Export To Detailed XML...", we noticed something funny. E.G. -

<File Index="1" Name="c:\projects\learning-service\learning.handlers.tests\activeusersupdatedtests.cs" ChecksumAlgorithm="SHA256" Checksum="15761E3D59A36FBFE26987EF2BA1429A96E255E7C284370DA11DF9E7FC5B8801" />

This is not matching the camel-casing used with the paths and filenames. Is there any way to change this?

 

1 comment
Comment actions Permalink

Hello Timothy,

Unfortunately, there is no such option in the current dotCover version. I've opened a corresponding issue in our bug tracker: https://youtrack.jetbrains.com/issue/DCVR-9798.

Please note that after the fix dotCover will preserve original file names in XML reports, but its internal file names processing still will be case-insensitive.

0

Please sign in to leave a comment.