How to configure DotCover Not to exclude referenced assemblies if they have zero coverage

Completed

When i run dotCover from console it include referenced assemblies that has some coverage.

I want to see full coverage of all projects in my solution including zero coverage.

I tried to use <ScopeEntry> in config.xml but it isn't helped.

How can i do it?

4 comments
Comment actions Permalink

Hello,

"Scope" parameter should have helped. Could you please send us your configuration file? Also please start dotCover with logging enabled and send us the log file. In order to enable logging please add the following keys to your command line: /LogLevel=Trace /LogFile=log_file_name

0
Comment actions Permalink

Hello.

Enabling Trace logging helped me to understand how to do it right. Thanks.

Could you help me achive similar result in TeamCity VsTest Build Step?

How can i pass Scope parameter to TeamCity if i don't know build folder. 

I tried absolute Path:

Scope="C:\TC\BuildAgent01\work\41fb7743682d5c61\**\bin\**\*.dll;C:\TC\BuildAgent01\work\41fb7743682d5c61\**\bin\**\*.exe"


and relative:

Scope="**\bin\**\*.dll;**\bin\**\*.exe"

Both does not give me the same result as manual run.

0
Comment actions Permalink

Please try to use TeamCity parameter references, like this (also the leading slash is required):

/Scope=%system.teamcity.build.checkoutDir%\Bin\**\*.dll

0
Comment actions Permalink

Thanks it helped!!!

0

Please sign in to leave a comment.