Html Coverage report empty with scope and filters - console - 2018.3.0-eap02

I'm trying to generate a coverage report for my solution.

My solution contains 10 projects and 1 unit test project.

My Unit Tests project does not test all of my 10 projects. So when I run coverage analysis (with console runner) on my UnitTests.dll the total of coverage is only calculated on dll that have unit tests. To fix that I tried to use the scope parameters with the filters parameters :

"C:\.nuget\packages\jetbrains.dotcover.commandlinetools\2018.3.0-eap02\tools\dotCover.exe  cover

/TargetExecutable="C:\.nuget\packages\xunit.runner.console\2.4.0\tools\net452\xunit.console.exe"

/TargetArguments="F:\MySolution\UnitTests\bin\x64\Release\UnitTests.dll -quiet -notrait "Category=Functional" "

/TargetWorkingDir="F:\Dir"

/Output="mySolutionCoverage.bin" /Scope="F:\MySolution\UnitTests\bin\x64\Release\OtherProject.dll" /Filters=+:OtherProject.*;-:*Test*;-:xunit.*"

 

After that I generate the report and the result is empty. If I remove the "+:OtherProject.*", the report is here but still withbad number

 

How can I achieve what I need ? Thank you !

2 comments
Avatar
Ekaterina Solovova
Comment actions Permalink

Hello Lexe,

In order to include not covered assemblies to the report "scope" parameter is sufficient. You don't need to specify "include" module filters.

What do you mean by bad numbers? You still don't see OtherProject.dll in the report even with scope specified?

Could you please send us dotCover console's output and log files of Trace level? In order to enable logs please see this instruction: https://dotnettools-support.jetbrains.com/hc/en-us/articles/206545979

Regarding module filters, please remove a dot and * from the string: "+:OtherProject". But in this case, the report will contain only OtherProject module and no others.

0
Comment actions Permalink

I'm really sorry to disturbed you. Finally I succeed to have other dll in the civerage with the scope parameters and I can't say to you what I did to do that :p

 

Thank you !

0

Please sign in to leave a comment.