Continuous Testing Failed to Process Coverage Results. The given key was not present in the dictionary.

Answered

Version: 2017.3.5 ReSharper Ultimate dotCover

Visual Studio 2017 Professional

 

All the tests passed but the coverage failed due to "Failed to Process Coverage Results. The given key was not present in the dictionary."  Any ideas to fix this problem?

10 comments
Comment actions Permalink

Hello, Tony,

Could you please drop results in the current session ("Drop results" button on the toolbar) and re-run analysis - will it help?

1
Comment actions Permalink

Thanks Fedor. It works. I never clicked that button before. It's interesting how the button is named. .

0
Comment actions Permalink

I'm encountering this same issue, where is this "Drop Results" button? I've tried "Remove Selected Tests" when having the root folder selected, but that didn't have any effect.

0
Comment actions Permalink

I also could not locate the Drop Results button. I'm running R# 2018.1.1.

I went to 

C:\Users\USERNAME\AppData\Local\Temp

And deleted it. Rebooted VS and I'm back in business.

0
Comment actions Permalink

In ReSharper 2018.1.x  "Drop coverage data" button is situated on the toolbar in the Unit Test Coverage window:


If it doesn't help, please do the following:

  • close your solution
  • go to %temp%\JetBrains\ReSharperPlatformVs[N]\vAny_[XXX]\CoverageData folder
  • find _[YourSolutionWithBrokenCoverage].[XXX] folder and remove it.
  • reopen the solution and repeat coverage analysis

 

0
Comment actions Permalink

Hello,

I did encounter exactly the same problem than you, but the solution of Fedor Buyvol-Kot didn't work for me (i tried both).

I still obtain the same issue in the test session (here is the string with the French version):

"2018.09.19 16:39:12.037   ERROR Coverage analysis: Processing coverage snapshots: 'C:\Users\m.racle\AppData\Local\Temp\ssd.Fetebos.tmp' failed: La clé donnée était absente du dictionnaire."
If you have an other idea i would be very happy.

0
Comment actions Permalink

Hello,

Could you please turn on ReSharper's logging, reproduce the issue and send us log files?
In order to turn on logging please start VS with the following command line arguments:

devenv.exe /ReSharper.LogLevel Trace /ReSharper.LogFile

Log files will be saved in the '%Temp%\JetLogs' folder with auto-generated names, so empty this folder before you launch VS.

Log files can be uploaded to our ftp server (please create an archive before uploading): https://uploads.services.jetbrains.com/

0
Comment actions Permalink

Hello,

Thank you for your help Ekaterina! I did upload my JetLog archive on your FTP server under the name : "M.Racle.Rollomatic_JetLogs.zip".

I hope it can help you find the issue. Tell me you need any other actions/files on my side.

0
Comment actions Permalink

Could you please try to update to 2018.1.4 or 2018.2.* version? Before starting VS after the update please remove %temp%\JetBrains\ReSharperPlatformVs[N]\vAny_[XXX]\CoverageData folder again.

0
Comment actions Permalink

Hello Ekaterina,

I have a good new for you, we just found the solution to our issue! Thanks very much for your help though.

The issue seemed related to "portable pdb" files instead of "full" pdb files. We had to add the following option to our .csproj  file:

 
 
<PropertyGroup Condition="'$(Configuration)|$(TargetFramework)|$(Platform)'=='Debug|net462|AnyCPU'">
 
<DebugType>full</DebugType>
 
<DebugSymbols>true</DebugSymbols>
 

</PropertyGroup>

Have a nice day!

0

Please sign in to leave a comment.