dotCover only covering my .Test assemblies

Completed

Hello,

 

I am having problems with using dotCover for the coverage of my code. Basically, I launch dotCover from the command line and try to cover tests run by NUnit. After the run, my report only contains my .Test assembly and not any of my source assemblies. I thought this might happen because of not having the .pdb files next to my dll's, so I tried both adding the /SymbolSearchPaths argument and adding the paths to the environment variable _NT_SYMBOL_PATH, but nothing worked. If it helps, here is the simplified version of my batch script to execute tests and generate coverage:

 

SET SYMBOL_SRC=C:\path\to\symbols\root

"C:\path\to\dotcover\dotCover.exe" analyse ^
/SymbolSearchPaths="%SYMBOL_SRC%directory1" ^
/TargetExecutable="C:\path\to\nunit\nunit-console.exe" ^
/TargetArguments="C:\path\to\tests\MyProject.Test.dll /noshadow" ^
/Output="dotCover_dir\coverage.html" ^
/ReportType="HTML"

 

I am totally stumped with this, I tried pretty much everything I could think of and/or find online. If anyone has any ideas of what might be wrong, I'd be very grateful.

1 comment
Comment actions Permalink

Bump. Am getting the same issue. 

Issue exists in 2016.2

Downgraded to 2016.1.2 and the highlighting works again.

0

Please sign in to leave a comment.