Cannot start trace "Profiler already Loaded"

 

 

Hi,

When I select the IIS worker process and click run I get the below message and cannot run a trace.  I've tried rebooting and have the minimal applications running, does anybody have any idea why this might be?

thanks.



14 comments

Hi,

 

Do you have any mocking tools/performance agents on your machine?

0

Hi,

No, I've stopped all that I can find.

0

Lianne,

 

Sorry for the delay with answer.

Could you please try to run our CleanUp utility, it cleans registry entries and environmental variables which are used by profilers/mocking tools. It is located in dotTrace installation folder (%LocalAppData%/JetBrains/Installations/dotTrace04 by default), you need to run the Command Prompt as administrator and run the CleanUpProfiler.x64.exe executable with /r and /t keys: "CleanUpProfiler.x64.exe /r /t". After that you will need to reboot the server.

0

I'm having this problem too.  Cleanup tool didn't fix it.

0

Hi Sean,

Could you please create a support ticket ("Submit a request" button in the upper right corner)?

0

I'm having the same problem on azure cloud service. How can I fix it?

 

Thanks.

0

I logged on today and the IIS process that the profiler was atttached to had died and that fixed the issue.  So I think you just have to kill whatever process you are trying to debug and restart it.

0

interesting. were you able to find how the profiler got attached? it's on azure. so I think, it will restart as soon as I kill it.

0

yeah i was the one who attached it earlier, it somehow just didn't become unattached when I closed out of dotTrace.

0

yeah. no matter if I restart the server, or try it on a fresh one, the same error occurs.

0

@Konstantin, do you have any suggestions to this azure cloud service specific case?

thanks.

0

Sean, I'm glad to hear that you figure it out. This issue could have arisen if you close dotTrace Home without detaching from IIS process.

Ahmet, could you please create a support ticket?

0

Actually, mine also got fixed by itslef :)

0

Please sign in to leave a comment.