Can't start ETW collector.

I'm unable to use Timeline profiling, either with dotTrace Standalone, or with the visual studio integrated.  It results in the error "Failed to start profiling: Can't start profiling. See below for more details:  Can't Start ETW collecor".


I've tried starting it with administrative permissions with no change, any insight?


Hi Brandon,


Could you please clear %localappdata%\Temp\JetLogs and %windir%\Temp\JetLogs folders, reproduce the issue and then create a support ticket ("Submit a request" button in the upper right corner) and attach all log files from these two folders to it?


I'm unable to use Timeline profiling as well... I have created the ticket and attached the log file as well..


I've got sometimes the same problem in dotTrace 2017.1.2 The only workaround I've found is to kill JetBrains.ETW.Collector.exe and JetBrains.ETW.Collector.Host.exe processes.


Hi Jan,


Could you please create a support ticket and send us log files?


I've got similar issue. Also please make the button to send logs


Hi Eugeniy,


It's a different error. Are you trying to run Timeline profiling of an UWP application built with old CoreCLR version?


Yes, timeline profiling on uwp, but version is anniversary update



This issue has been fixed for CoreCLR after the Anniversary update: , but CoreCLR for UWP has a different schedule, so as far as I understand this fix is not included to the latest version of CoreCLR for UWP apps.


Facing the same issue. Cant start timeline profiling and get the message 

Tried it several times. The issue resolves after a reboot. This is so frustrating.. Can you let me the same of the ETW provided and how to delete it? 



Do you have Process Hacker installed on your machine? You need to close it in order to resolve this issue.


Facing similar issues. Cannot get the dotTrace profiling to work, both Timeline and Sampling profile types. Frustrating! I keep getting the  "ETW service collector was already launched" error.


Hello Siva,

We need some additional information to analyze your issue. Could you please perform the following:

- Clear %localappdata%\Temp\JetLogs and %windir%\Temp\JetLogs folders

- Kill JetBrains.ETW.Collector.exe and JetBrains.ETW.Collector.Host.exe processes if any

- Restart dotTrace 

- Reproduce the issue

- Create a support ticket ("Submit a request" button in the upper right corner) and attach all log files from %localappdata%\Temp\JetLogs and %windir%\Temp\JetLogs.


Please sign in to leave a comment.