ConsoleProfiler - No snapshots have been collected

I am trying to use the ConsoleProfiler, everything seems to be running fine but I get "No snapshots have been collected".

Console output:
C:\JetBrainsCLT>ConsoleProfiler.exe dotTrace_Config.xml snapshot.dtp
Console Profiler 2016.1 build 105.0.20160414.155338 Copyright (C) 2011-2015 JetBrains s.r.o.

...

Profiling is successfully finished in 60.906 seconds
No snapshots have been collected

dotTrace_Config.xml:

<root>
<HostParameters type="LocalHostParameters" />
<Argument type="StandaloneArgument">
<Arguments IsNull="False">
</Arguments>
<FileName>C:\Sourcecode\Project\bin\Debug\Test.exe</FileName>
<WorkingDirectory>C:\Sourcecode\Project\bin\Debug</WorkingDirectory>
<Scope>
<ProcessFilters />
</Scope>
</Argument>
<Info type="PerformanceInfo">
<MeasureType>Sampling</MeasureType>
<MeterKind>Rdtsc</MeterKind>
<InjectInfo>
<SymbolSearch>
<SearchPaths />
</SymbolSearch>
<Scope>
<PatternFilters />
<DenyAttributeFilters />
</Scope>
</InjectInfo>
</Info>
<CoreOptions type="CoreOptions">
<CoreTempPath IsNull="False">
</CoreTempPath>
</CoreOptions>
<HostOptions type="HostOptions">
<HostTempPath IsNull="False">
</HostTempPath>
</HostOptions>
</root>

 

1 comment
Comment actions Permalink

Hi Jesse,

 

Could you please try to run console profiler with command line arguments instead of XML configuration file (like "ConsoleProfiler.exe /app=C:\Sourcecode\Project\bin\Debug\Test.exe /profiling_type=Sampling snapshot.dtp")? If it will not help, could you please create a support ticket ("Submit a request" button in the upper right corner)?

0

Please sign in to leave a comment.