Errors & trouble submitting them.

I am encountering an error when running coverage for all tests in the solution. The solution I am testing contains several projects, two of which are for testing. One project contains only unit tests and the other contains integration tests. dotCover's exception browser will not let me submit the error. When I try to submit I get:

The remote server returned an error: (401) Unauthorized.

The error I am trying to submit is:

Client controller exception: Error in the application. (MSTest).

Technical Information:
[Installed ReSharper: ReSharper 5.1 Version=5.1.1727.12, Built=2010-07-07T20:40:20]
Client controller exception: Error in the application. (MSTest)

--- EXCEPTION #1/1 [LoggerException]
Message = “Client controller exception: Error in the application. (MSTest)”
ExceptionPath = Root
ClassName = JetBrains.Util.LoggerException
Data.LastExtension = cs
Data.ProjectTypeGuids = fae04ec0-301f-11d3-bf4b-00c04f79efbc
Data.VsVersion = 9.0.30729.1
HResult = COR_E_APPLICATION=80131600
StackTraceString = “
  at JetBrains.dotCover.RsPlugin.CoverageTaskRunnerHostController.LogError(String message) in c:\BuildAgent\work\619db7e4c7376c5e\RsPlugins\Src\RsPlugin.5.0\Src\CoverageTaskRunnerHostController.cs:line 101
     at JetBrains.Profiler.RsPluginBase.ProfilerTaskRunnerHostControllerBase`1.ClientMessage(String message) in c:\BuildAgent\work\619db7e4c7376c5e\Profiler\RsPlugins\Src\RsPluginBase.5.0\Src\ProfilerTaskRunnerHostControllerBase.cs:line 72
     at JetBrains.ReSharper.UnitTestExplorer.UnitTestRun.ClientControllerMessage(String message)
     at JetBrains.ReSharper.UnitTestFramework.UnitTestServer.ClientMessage(String runId, String message)
     at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
     at System.Runtime.Remoting.Messaging.StackBuilderSink.PrivateProcessMessage(RuntimeMethodHandle md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
     at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)
     at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
     at System.Runtime.Remoting.Messaging.ServerObjectTerminatorSink.SyncProcessMessage(IMessage reqMsg)
     at System.Runtime.Remoting.Messaging.ServerContextTerminatorSink.SyncProcessMessage(IMessage reqMsg)
     at System.Runtime.Remoting.Channels.CrossContextChannel.SyncProcessMessageCallback(Object[] args)
     at System.Runtime.Remoting.Channels.ChannelServices.DispatchMessage(IServerChannelSinkStack sinkStack, IMessage msg, IMessage& replyMsg)
     at System.Runtime.Remoting.Channels.DispatchChannelSink.ProcessMessage(IServerChannelSinkStack sinkStack, IMessage requestMsg, ITransportHeaders requestHeaders, Stream requestStream, IMessage& responseMsg, ITransportHeaders& responseHeaders, Stream& responseStream)
     at System.Runtime.Remoting.Channels.BinaryServerFormatterSink.ProcessMessage(IServerChannelSinkStack sinkStack, IMessage requestMsg, ITransportHeaders requestHeaders, Stream requestStream, IMessage& responseMsg, ITransportHeaders& responseHeaders, Stream& responseStream)
     at System.Runtime.Remoting.Channels.Ipc.IpcServerTransportSink.ServiceRequest(Object state)
     at System.Runtime.Remoting.Channels.SocketHandler.ProcessRequestNow()
     at System.Runtime.Remoting.Channels.RequestQueue.ProcessNextRequest(SocketHandler sh)
     at System.Runtime.Remoting.Channels.SocketHandler.BeginReadMessageCallback(IAsyncResult ar)
     at System.Runtime.Remoting.Channels.Ipc.IpcPort.AsyncFSCallback(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* pOverlapped)
     at System.Threading._IOCompletionCallback.PerformIOCompletionCallback(UInt32 errorCode, UInt32 numBytes, NativeOverlapped* pOVERLAP)


This is the second machine and third version of dotCover that I am experiencing this issue on. Another issue that I am encountering that may be related is that when running all tests in solution (without code coverage) all tests run but the session itself never completes. The test runner gets through the last test and then just hangs. If I click stop test run, the run stops and shows a completed state. This issue also just started occurring after install of the last few versions of dotCover.

Hopefully I have included everything that you need to research this issue. If not then feel free to request more information. I know that none of this is in the form of a question but I'm stuck, where do I go from here?

~Greg

2 comments

Hello Greg,
Thank you for the feedback!
Do you submit exceptions anonymously or as a registered user?
If second, please check your login name and password.

Regarding other issues:
1) dotCover can't affect running all tests without coverage, this could be a problem with unit tests themselves.
For this case it's interesting to take a look at the ReSharper logs.
You can enable them by running VS with /ReSharper.LogFile=path_to_the_log_file key.
Also you can try to run console version of MSTest to check that tests run fine.

2) Do you have default VS coverage turned on? It affects the dotCover behaviour.
What are the versions of your Windows & VS? Do you have x86 or x64 system?
Do you have ignorred tests in your solution? dotCover logs would be also helpful,
you can find them in %TEMP%/JetLogs folder.

You can contact me directly by the email (ruslan dot isakiev at jetbrains dot com)
I'll be glad to help you resolving the issue.

0

Discussion taken to email. Will try to post solution once it has been discovered.

0

Please sign in to leave a comment.