dotCover version compatibility...

Hi,

I have "trial" dotCover 1.0.1 (1.0.120.2), with VS2008, R# 4.5 (4.5.1288.2) and an old dotTrace 3.1 (build 355.1000).

I dont believe I can go to R#5 yet, we have not paid for the licence, same for upgrading dotTrace.

On the unit test sessions window, I see a dotTrace/profile button, but no coverage button.

Is this a compatibility issue, do I need to uninstall or upgrade dotTrace?

Can I just disable the R# integration to get dotCover working?

Thanks,
Chris

8 comments

When I select the dotCover | Cover Startup Project menu option, I get the attached error.



Attachment(s):
dc-start2.PNG
dc-start1.PNG
0

Will try uninstalling dotcover, dottrace and resharper and then installer resharper 4.5 (in vs2008) and then dotcover - hopefully that combination works (and I am not out of my dotcover trial period).

0

Oops - just noticed this email from Jetbrains:

Hello Chris,
dotCover integrates with ReSharper 5.0 and above.
However even without ReSharper it's still possible to perform coverage analysis of tests executed by any external runner.
See (dotCover -> Cover Application) in main menu.

So, perhaps I am not going to get far with ReSharper 4.5...

0

The reinstall did not help, and I guess not surprising given the above comment.

I tried the "Cover Application" option, but not sure how to use it...

Do I configure it to use a Standalone application to run the MSTests ?  Silverlight, WebDev, Windows Service dont seem appropriate.  Perhaps IIS App or .NET process is the way to go?

I am testing an MVC app using using MSTest.

Thanks,
Chris

0

2 days left until the end of trial period

:(
0

Hello Chris,

I'm sorry for the delayed response.

As it was mentioned in the email, dotCover integrates with ReSharper 5.0 and above.

To run tests without ReSharper you should do the following:

dotCover -> Cover Application -> Standalone application.

You'll need to specify

- path to the mstest executable (e.g. C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\IDE\mstest.exe)

- commandline arguments (e.g. /testcontainer:SampleApp.Tests.MSTest.dll)

- working directory (e.g. C:\SampleApp\bin\Debug\)

- "profile child processes" option should be turned on.


coverage_configuration.png

I'll send you a key with extended trial period by email.
Please contact me if you'll have any questions.
0

Hi,

Many thanks for the detailed instructions.

This worked great, I now have coverage info in VS.

I was hoping this would help me track down the TeamCity/dotCover problem, but it hasnt :(

http://devnet.jetbrains.net/thread/292759?tstart=0

Thanks,
Chris

0

Please sign in to leave a comment.