dotCover 2.2 coverage analysis fails

I'm running Resharper 7.1.1000.900 and docCover 2.2.515.8 with Visual Studio 2012.

I've been working on moving some utility libraries to .Net 4.5 and porting some to Window Store (WinRT).  I've got a bunch of MSTest based Unit Tests for the library and want to see what my code coverage is.

I can run the unit tests fine using the ReSharper test runner, but when I try "Cover with dotCover". It says:  Inconclusive:  Test wasn't run, in the unit test window
and the details portion says:

Product installation directory has no read access rights for WinRT applications;  No shapshots created)

This isn't a WinRT project, although there are WinRT projects in the solution, also, I looked in the installation directory and there doesn't appear to be any WinRT directories there for it to read.

Michael

6 comments

Hi Michael,

Thank you for the feedback.
Unfortunately, it's a known issue. You can find current workaround here:  http://confluence.jetbrains.net/pages/viewpage.action?pageId=49448495
If it's necessary we could prepare a special build with a fix for you.

Regards.

0

I'm having the same issue, when running dotCover on a Windows 8 machine from incide TeamCity.

I've tried the fix in the link, and the "ALL APPLICATION PACKAGES" user has the specified permissions to the Program Files x86 and the Program Files x86\JetBrains directories.

It appears you have to give the ALL APPLICATION PACKAGES user those permissions to the C:\TeamCity directory as well I think.

0

Hi Sam,

This problem is fixed in the upcoming dotCover 2.5. Please try the following dotCover build:
http://download.jetbrains.com/dotcover/dotCoverConsoleRunner.2.5.570.17.zip
In order to update dotCover on TeamCity you should put the zip in the following directory on your TeamCity server:
TeamCity\webapps\ROOT\WEB-INF\plugins\dotNetRunners\agent\dotCover.zip (full path may vary a bit)
When TeamCity will detect a new zip, dotCover console runner will be deployed on all of the build agents.
Please let us know if this helps.

Regards.

0

I've tried installing the new version but nothing seems to happen - do I need to click anything or will it just work if I put the zip in the right place?

For me, this directory contains just .jsp files, no agent subdirectory:

C:\TeamCity\webapps\ROOT\plugins\dotNetRunners

I created a subdirectory, agent, and put the zip in there.

I wasn't sure whether to name it dotCoverConsoleRunner.2.1.471.15.zip (as it's downloaded) or dotCover.zip (as you suggest).

Please can you help me to get this installed? How will I know when it's been pushed out to the agents?

I'm using TeamCity 8.0.3.

0

Hi Tom,

I'm terribly sorry! There is an error in the link in the previous post. The actual link is here:
http://download.jetbrains.com/dotcover/dotCoverConsoleRunner.2.5.574.60.zip

Regarding that you have no agent subdirectory: it seems that you have missed WEB-INF subdirectory in the path: C:\TeamCity\webapps\ROOT\WEB-INF\plugins\dotNetRunners\agent
You should rename file dotCoverConsoleRunner.2.5.574.60.zip to dotCover.zip. I guess that TeamCity should detect a new zip and update build agents within several minutes.

Please let me know whether it helps.
Best regards.

0

Hi Ekaterina,

Thanks, that worked perfectly. The agents disconnected with a "will upgrade" message and then came back online with the new version within a couple of minutes.

Thanks,

Tom

0

Please sign in to leave a comment.