Inconclusive: Test wasn't run in dotCover 2.5

Hi,

since today I get the "Inconclusive: Test wasn't run" message on all of my tests when I try to cover them in VS 2012 and VS 2010 (both with dotcover's builtin Nunit 2.6.2).
The tests are running normally when I execute them with Resharper in VS 2012 (Resharper 7.1).

Is there any solution to solve that in dotCover 2.5? I just found solutions for dotCover 2.2 and smaller and got the impression that this was fixed in 2.5?

What's also strange is when I right click on my cs-File where the test is implemented and click on "cover tests with dotcover" it says that there are no tests in the file. But in the file itself there are the icons for running/debugging/covering the tests...

Thanks,
Carsten

7 comments

Hello Carsten,

Could you please provide more details about the issue:
- which unit test runner do you use - ReSharper's or dotCover's one?
- did you perform some specific actions just before the problem first occurred? May be you cleaned your disk, upgraded some software, turned on/off unit test runner or something else?
- can you see your tests in the Unit Test Explorer window (menu dotCover/Unit Tests/Unit Tests)?
- could you please run VS with dotCover's logs switched on, reproduce the issue and send me the log file? In order to switch on dotCover's logs please run VS with the following command line key: /dotCover.LogFile log_file_name.

Thanks in advance. Best regards.

0

Hi Ekaterina,

sorry for my late reply - there was an official holiday last week in Germany.

I try to give you the answers to your questions:

- which unit test runner do you use - ReSharper's or dotCover's one?
* i'm not sure. How do I see this? In dotCover's options dialog for Nunit "Enable Nunit support" is activated and "builtin Nunit 2.6.2" is selected. The respective options dialog in Resharper looks exactly the same.

-  did you perform some specific actions just before the problem first  occurred? May be you cleaned your disk, upgraded some software, turned  on/off unit test runner or something else?
* i'm not aware of any changes that could affect dotcover. Maybe i used CCleaner.

- can you see your tests in the Unit Test Explorer window (menu dotCover/Unit Tests/Unit Tests)?
* no. The menu item "dotCover->Unit tests" is disabled.

-  could you please run VS with dotCover's logs switched on, reproduce the  issue and send me the log file? In order to switch on dotCover's logs  please run VS with the following command line key: /dotCover.LogFile log_file_name.
* I added the file as attachment.

Kind regards,
Carsten



Attachment(s):
dotCover.log.zip
0

Hi Carsten,

Thank you for the information!
You can see whether dotCover's unit test runner is turned on or off in the dotCover/Options dialog ("Unit Testing" page, "Enable Unit Testing" check box). But if dotCover/Unit Tests menu item is disabled, it means that dotCover's unit test runner is turned off.

It can be seen from the log that there are some problems with internal dotCover processes. Unfortunately I need some additional information from you for the further investigation of the problem.
Could you please perform the following steps:
- remove all files from the %TEMP%/JetLogs folder (%TEMP% is your temp-folder, most probably C:\Users\Your_user_name\AppData\Local\Temp);
- reproduce the problem with dotCover logs turned on;
- send me all files from %TEMP%/JetLogs folder.

Thanks in advance. Best regards.

0

Hi Ekaterina,

here it is.

By the way: The problem not only occurs on my machine - another of our developers reported the same error to me. Common on both cases is that we previously used dotCover 2.5 EAP versions - and we're using the same solutions, of course. Is it a problem that maybe the previous EAP version left some "garbage"?

Kind regards,
Carsten



Attachment(s):
JetLogs.zip
dotcover2.log.zip
0

Hi Carsten,

Thank you for the information again!
Could you please perform the following steps:
- save somewhere all files from %TEMP%\JetBrains\PartsCache folder;
- remove PartsCache folder;
- restart VS and try to reproduce the problem again;
- in case if the problem is solved send me please the saved files (for the further analysis).

Best regards.

0

Hi Ekaterina,

I think the problem is solved :-)  There are coverage results - but the menu item dotCover->Unit tests still is disabled. Is that correct?
I attached all the files for analysis.
Thank you very much!

Kind regards,
Carsten



Attachment(s):
dotcover3.log.zip
PartsCache_after.zip
PartsCache_before.zip
0

Hi Carsten,

I'm glad to hear that it works now!
Disabled "dotCover/Unit Tests" menu item is ok. It just means that dotCover's embedded unit test runner is turned off and you use ReSharper's one to run, debug and cover unit tests. ReSharper's and dotCover's "Unit Tests" menu items are similar to each other.

Thank you very much for the assistance. Best regards.

0

Please sign in to leave a comment.