installed dotcover several times, still no coverage options on unit tests; how to get it integrated?

JetBrains dotCover 2.0 Full Edition
Build 2.0.419.8 on 2012-06-08T20:48:32

Visual Studio 10.0.30319.1.

I just got a notice today that dotCover got an update. OK, I install it. Well after the install I still have no options for getting coverage on an Nunit test. A coworker has the same setup and does have the coverage option. I've reinstalled dotCover several times.

From what I've read I should be able to click on the little bubble to the left of a test and get coverage for that test. I've never seen that option though.

What's the next step to fixing this?
7 comments

Hello Justin,
Could you please tell the following details:
- do you have dotCover in the VS main menu?
- do you use ReSharper? if yes, which version?
- what is the full nUnit version?

Also it is possibly to check few things:
- dotCover package is not skipped during VS load (run VS with the /resetskippkgs commandline key)
- dotCover is not suspended (in VS: Tools->Options->dotCover->Resume)

Looking forward to your feedback.

0

Dotcover is in VS menu.
Resharper, yes, 6.1.1000.82
Nunit 2.5.10

Running VS from command line with /resetskippkgs didn't change anything.
Dotcover was not suspended. Suspending it and resuming didn't change anything.

I've attached a screenshot of what my unit test context menu in VS looks like as well as the dotCover menu.



Attachment(s):
nunit dotcover 2.png
nunit dotcover.png
0

Ok, then there is else one thing to try.
Could you please repair ReSharper install?
(Control Panel -> Programs and features -> JetBrains ReSharper -> Repair)
It is important to have correct binding redirections for ReSharper assemblies in devenv.exe.config.
Without binding redirections ReSharper plugins can't be properly installed.
However, sometimes config file is incorrectly modified by some third-party tools.
Repairing fixes that.

0

It appears that the Repair option fixed it. Seems odd though, since I only just installed dotCover a few weeks ago and it never worked in the first place. Maybe a bug in your installer? Do you have to have VS closed when you install?

0

Hi Justin,
Thank you for the info!
Our installer is mature enough, we use the similar technology in all our .net products, so during recent years it was pretty well tested.
Nevertheless, I'll ask our QA team to perform additional checks for your scenario.

0

Hi,

I have a similar issue with VS 2012 and dotCover 2.7.2.176. A repair for the Resharper-installation didn't help in my case.

Strange enough: I can use dotCover with VS 2010 as usual.

0

Hi Roland,
In dotCover 3.0 / ReSharper 9.0 release we've introduced a new installer which installs/updates all .net tools at once.
If your license allows upgrade for all products, please try the new version:
http://download.jetbrains.com/resharper/ReSharperAndToolsPacked01Update1.exe
The above mentioned issue should be automatically solved.
Please note that with this new version the update will affect all products.

0

Please sign in to leave a comment.