Profile button disabled in Visual Studio 2008

I am trying to use dotTrace 3.1 to profile my unit tests, but the Profile button is always disabled. I have Visual Studo 2008 running on Vista x64. I also have resharper 4.5 installed.

Is this configuration supported? How do I enable Profile button?

2 comments
Comment actions Permalink

Hi! The problem here might be that Visual Studio runs as a x86 application and, because of isolation, doesn't see x64 registry settings. If you profile x86 applications, install 32-bit version of dotTrace - this will help.

WBR, Oleg

0
Comment actions Permalink

Thanks! That worked.

I cannot profile 64 bit applications now, but that's not a big thing. I've tried to install 64 and 32 bit versions side by side, but with no success.

0

Please sign in to leave a comment.