dotTrace stays at "connecting"


I have installed 3.1 version of dotTrace on 2003 server. The application is .NET 2.0 web application running on IIS 6.0. The user account is a local admin.
Given this scenario, when I profile the web application, the Start Profile and Get Snapshot buttons are remaining disabled.

I registered the dll's mentioned in the FAQ and it succeeded. Also, the sample application provided with dotTrace is working fine. However the web application alone is not working fine.

Any help would be appreciated.




I have such problem.
You have found the decision?



Dear akbhems,

IIS runs aspnet_wp.exe and w3wp.exe under specific user account (ASPNET on my Vista x64).

This account must have following rights:
- %Program Files%\JetBrains\dotTtarce 3.1\JetBrains.dotTrace.Core.*.dll files - read only access
- %WinDir%\Temp - read/write access

It should help you to profile.

Best wishes,
Mikhail Pilin



I am using IIS 5.1 and even after registering the dll I am still having the problem above. Can you help me to fix it? I have no clue how to make it work in Web Applications.
I already gave permission to the dll's above.



I can profile an application with DotTrace 3.1
I can NOT profile a service or a WEB application with DotTrace 3.1. The status in the control box is always "Waiting" and the "Start Profiling" and "Get Snapshot" buttons are disabled.

- I registered regsvr32 JetBrains.dotTrace.Core.ia32.dll as advised
- I added also the following privileges:
   - %Program Files%\JetBrains\dotTtarce 3.1\JetBrains.dotTrace.Core.*.dll files - read only access
   - %WinDir%\Temp - read/write access

But I still can not profile a service or a Web application with DotTrace 3.1.

Thanks for your help


Dear Users,

Probably you have firewall. Please temporary disable it.

WBR, Mikhail Pilin


I had this issue also, what made it finally work was mapping the site in iis and profiling with the mapped address instead of specifying the port.  I was trying to profile by launching http://localhost:62960 but had to change it to http://localhost/mappedaddr .



Has there been a resolution to this problem. I'm running into the same issue. I've got 64bit, Windows Server 2008, IIS 7...running a local web application. The profile just stays at connecting. Any help would be much appreciated.



Dear Sam,

I'm sure you have tried instruction above. So, I have no more recomendations now. I need more information about your IIS configuration to solve the problem. Could you make some configuration screenshots and send them to me at Mikhail.Pilin (A) JetBrains (dot) com?

Mikhail Pilin


Dear Mikhail,

I have done the following:
- Run regsvr32 JetBrains.dotTrace.Core.ia32.dll
- Set priviliges for JetBrains.dotTrace.Core.ia32.dll and Temp/ as advised
- Disabled firewall

When Control Profiling window is up, i check the task manager if aspnet_wp.exe is runned. And it is there with ASPNET as username.

However I still have no luck in profiling a web application and WCF service hosted in IIS successfully.

FYI, I'm currently trying to profile a .NET 3.0 Framework web application hosted in IIS version 5.1.

Could you please kindly assist me in figuring out what's missing here ?

Thank you in advance.

Best Regards,



I think I found the solution to the problem (at least to my manifistation of it). I had the same issue, and turns out I still had enviroment variables for .NET profiler still set from trying out another profiler. This is what I did to fix it:

cmd> set COR_PROFILER=

Hope this helps someone else as well.

-- Greg


I had the same "connecting" problem and was able to get past it on:

Windows 7 Professional x64


  • Installing the 64-bit dotTrace installer
  • running: C:\Program Files (x86)\JetBrains\dotTrace 3.1>regsvr32 JetBrains.dotTrace.Core.amd64.dll



In my case the problem was that the application was using .NET Framework 4.0. I guess dotTrace Performance 3.x works only for applications using older versions of .NET. I tried the dotTrace 4.0 trial and it managed to profile correctly.


You are partially right. dotTrace 3.1 doesn't recognize CLR4 apps, but dotTrace 3.5 does recognize.
WRB, Ivan Shakhov


Please sign in to leave a comment.