Remote profiling through VPN

Hi,

I followed the steps from the remote profiling guide but I can't connect.

I've got a VPN link to the remote server. The remote server is on a different domain. I added entries for the remote host names (partial and full).

When I connect to the remote server through the IP address, I can see the agent prints "Authenticated as passphrase match" and then the client tells me it cannot connect to the host ("no such host").
When I use the partial or full hostnames it doesn't seem to connect at all (the agent doesn't print anything).


How can I go forward to resolve the connection issues?

Cheers.

7 comments

Hi,

You will need to disable the firewall on your development computer (the one with dotTrace installed).
Please follow up after trying.

Regards,
Ivan Shakhov

0

Hi,

There's no firewall on my computer (the Windows firewall is disabled).
The firewall is disabled on the target computer as well (we use appliance firewalls when not going through the VPN).

I can telnet to the port but I get rubish back (which I guess makes sense since it's not a telnet session).

Cheers.

0

In current implementation first dotTrace connects to agent through specified port, and second agent connects back through some port range.
So, when you get print "Authenticated as passphrase match" at agent it indicates that first part was success, but than you get "no such host", which indicates that connection back from agent doesn't work.
Major reasons are firewall or antivirus at dotTrace computer.

0

One more thing to check:
1. Does your VPN connection share dns?
Could you connect through dnsName or dnsName.domainName instead of using IP.

The cause for this is that backward connection still requires shared dns to locate your dotTrace computer.
Unfortunatelly such behaviour is unavoidable for MS Remoting.

Please write me directly to Ivan.Shakhov@jetbrains.com if you need some extend for the evaluation license.

WRB, Ivan

0

Our setup doesn't share DNS. It looks like I can't use remote profiling at the moment then :(

Thanks for your time, I know what to ask to my admins next time I need to do remote profiling.


I tried your product because we had a very high CPU load on our servers. It turns out it wasn't related to the code but to the machine configuration so I haven't actually used your product much (it turns out that running a separate WCF service in a console for a while makes IIS lower its CPU usage A LOT for its hosted service. Seems completely unlikely but actually works on our machines repeatedly.)

It left a good impression and I'll be sure to give it some time when we go around improving our application's performance.

Cheers.

0

I had a similar problem, but I did find a workaround.

Actually, there's three.  The cleanest way would be to change dotTrace's remoting to set the machineName setting on its (I'm guessing) TcpChannelServer.  Obviously, we can't do that (devs, lookee here!)
The next cleanest way would be to set machineName via the application config file, which I tried but didn't quite work out.  I'm almost sure this is possible, but I didn't have time to play around with it more.

Thus, I present the third way, which is rather complicated but does work.

I'm assuming that you, like me, are not on any sort of company network and thus are free to change around your computer name.

1.  Get an account with a dynamic DNS provider (they'll provide you with a DNS mapping for an IP that you specify.)  Set this DNS entry to point to your VPN IP that you want to use.
2.  Set your machine name to the DNS name you got above. The way I did it is to keep my computer name X, and set the DNS suffix property to Y.com, thus making my machine name X.Y.com, which matches my dynamic DNS entry.

Thus, the remote machine will do a DNS lookup on your machine and get the proper IP.

0

Thank you for the information, I hope it will help.

Anyhow remote profilation will be redesigned for the next major version to avoid back connections.

WBR, Ivan Shakhov

0

Please sign in to leave a comment.