dotTRACE Memory always says "Connecting"

Whenever I try to run dotTRACE Memory 3.5 on a stand-alone Windows .NET application, the "Control Profiling" dialog appears and the only option enabled is "Terminate Application".  The status always says "Connecting" but never says connected.  What am I doing wrong?

6 comments

Hello Owen,
It may be an effect of other profilers (like ANTS or VS2010's built-in) installed, even if now you don't use them. Please contact me by e-mail (alexandra.rudenko@jetbrains.com), and I'll send you our utility for cleaning registry and temp folders.

0

I ran the utility you sent me and I am still getting the same problem.  What should I try next?

0

Hi Owen,
Sorry for inconvinience, I've forgotten to tell you conditions required for cleaning registry and temp:
1. stop IIS before you run utility: open IIS manager, select IIS root node (it's called like your computer) and click Stop on the right;
2. run the utility as administrator (launch command line or any tool in which you run the app by right-click -> Run as Administrator).
Please let me know if it doesn't help.

0

I apologize for the delay as I have been on travel.  I have done as you requested and am still experiencing the problem.  My application starts up but the "Control Profiling" dialog only has "Terminate Application" enabled and remains in the "Connecting" state.

My application is a 64-bit .NET 4.0 application.  Does the dotTRACE Memory support 64-bit applications?



Attachment(s):
ControlProfiling.png
0

Fixed it.  I had first installed the 32-bit version of dotTRACE and then installed the 64-it version on top of the 32-bit version.  Once I uninstalled it and only installed the 64-bit version, it started working properly.

0

Hi Owen,
Thanks for letting me know! Glad to hear it works now.

0

Please sign in to leave a comment.