Why do I need .NET 4.0?

The workplace standard here in .NET 3.5.  They don't even allow .NET 4.0 to be installed on the machines.  However, I'd like to use dotPeek, but it tells me I need to install .NET 4.0.  Is it running in .NET 4.0, or just needs it if you want to decompile .NET 4.0 dlls?

4 comments

I don't know why dotPeek has .NET 4.0 as a pre-requisite....
Maybe is such a case Reflector is an alternative or workaround? Runs even with .NET 2.0 ....

0

Same restrictions here. I want a dotPeek running on .NET 3.5.

0

Unfortunately, dotPeek uses some new APIs introduced in .NET 4.0.
It was decided not to implement it ourselves.

0

My assumption is that there's less development time dedicated to this product, therefor they went with the easiest approach and decided to use the most recent version for features that are already in the framework rather than developing these features but I think it's quite wrong because a large base of users still uses .NET 3.5.

Couldn't you disable features or something rather than preventing them to use the product completely?

0

Please sign in to leave a comment.