dotPeek has taken over my Visual Studio Compare!

Downloaded the installer version of

JetBrains dotPeek 1.0 Full Edition
Build 1.0.0.8644 on 2012-05-09T17:59:52

Ran it with something, not much different from whatever the last version I had was, all good.

Went back to working on code. Did a compare (I have WinMerge as a custom compare/merge tool in VS 2010), and...dotMerge splash, and WinMergeU in the list of files! (no, it's not written in .NET).  Went into VS and re-edited the parameters. Still happens. Uninstalled dotPeek. Whew, it went away.

Any idea wtf has happened here?

5 comments

It also seems to have changed the icon on my quick start bar for VS to the one for dotPeek. Perhaps some ninja associations? Was still there when I exited and re-started up VS long after the uninstall.

Edit: Definitely. Finally had a chance to look at my desktop, and every EXE and pointer to EXE icon is now the Phi of dotPeek.

Message was edited by: Peter Smith

0

Hi,

Very strange behavior this is. Could you please provide some screens of it? We haven't been reported about anything like this before, actually. Are you sure that your Windows installation is fine? Maybe it is a good idea to restore default file associations for the OS...

Thanks.

0

I uninstalled dotPeek, still full of Phi.

Rebooted, and everything was back to normal.

I'll very carefully install again now...because of course, now I'm curious.

0

Reinstalled, did it again. Tried to reply here and paste in a section of my screen, but, no go. But it's pretty simple...it changes the icons on the screen and in the Quick Link bar of EXE files, to a white-backed version of the icon in the file. It also changes shortcuts to the same icon, with of course the little arrow overlay in the lower left corner (that I haven't disabled).

As well, Visual Studio is acting strangely. When I right-click in History to do a compare, dotPeek runs, and tries to decompile WinMerge for me.

Uninstalling again. When I get the time, I'll clone my machine into a virtual one, and enter in a bug report; for now, hopefully someone else has this problem and affirms that it exists for more than just me.

0

Could you please check for the Widnows file associations for *.dll and *.exe files? Make sure that
they are set not to be associated with dotPeek.

Thanks!

0

Please sign in to leave a comment.