Shortcut Alt+\ doesn't work

Hi,

first of all I have to say thank you for that great tool. I have used reflector and ilspy before, but now dotPeek is the tool of my choice :-)

Now to the issue: when I am within a decompiled file, pressing Alt + \ should go to the file member. This doesn't work - nothing happens. When I click on the corresponding menu item the search box shows up.

Any idea what's wrong here?

Thanks,
cetama

PS: I have installed resharper as well - perhaps someone is "eating" the shortcut

8 comments
Comment actions Permalink

Hi,

Which keyboard scheme are you using for dotPeek? Is it ReSharper or IDEA one?
Please let me know.

0
Comment actions Permalink

Hi,

I am using the Resharper keyboard schema.

0
Comment actions Permalink

Thanks for the info.

Coudl you please try to apply IDEA scheme in the 'Tools | Options | Environement | General' in dotPeek and check the Ctrl+F12 shortcut for it. After that, please try to set the VS scheme back and check if it helps.

Please let me know the results.

0
Comment actions Permalink

Hi,

I already tried to switch to IDEA and there the shortcut works. Switching back to VS has no influence - shortcut still doesn't work.

Thanks,
cetama

0
Comment actions Permalink

Hi Franz,

Thanks for the info. This is only possible, if some 3rd-party software is installed in the system and is using the Ctrl+T shortcut.
ReSharper does not interference with dotPeek shortcuts at all.

Any kind of screenshot-maker-program, antivirus, video driver, etc. may be doing this.
Thank you.

0
Comment actions Permalink

Hi Alex,

this is strange because the resharper in VS works with the same keyboard schema without any problems.

Thanks,
cetama

0
Comment actions Permalink

Hmm I think I found the reason for this issue. I am using a german keyboard (qwertz). So when I press ALT+\ nothing happens. When I use the keys from the english keyboard layout (Pressing the ALT key and the key left of Z) the file members dialog is visible.

Can you double check?

Thanks,
cetama

0
Comment actions Permalink

Hi Franz,

Thank you for the information. I've logged this issue as a Task for our QA Team to check it here in YouTrack: http://youtrack.jetbrains.com/issue/DOTP-5222

Thanks for the report!

0

Please sign in to leave a comment.