dotPeek symbol server not working

I've gone through the setup instructions for enabling the dotPeek symbol server here: https://confluence.jetbrains.com/display/NETCOM/dotPeek+Symbol+Server+and+PDB+Generation

But it isn't working.  When I break on a method call I want to step in to, I get a popup dialog asking me to browse to the source file (which I don't have).  When I cancel, I get the "Source Not Found" tab.  Looking at the source search information, I see:

Locating source for 'c:\Sandboxes\ComponentSpace\SAMLv20\Library\Protocols\SAMLMessageSignature.cs'. Checksum: MD5 {24 67 a8 e1 7d e5 52 58 cb 9c 4c 58 5d 23 ec 4a}
The file 'c:\Sandboxes\ComponentSpace\SAMLv20\Library\Protocols\SAMLMessageSignature.cs' does not exist.
Looking in script documents for 'c:\Sandboxes\ComponentSpace\SAMLv20\Library\Protocols\SAMLMessageSignature.cs'...
Looking in the projects for 'c:\Sandboxes\ComponentSpace\SAMLv20\Library\Protocols\SAMLMessageSignature.cs'.
The file was not found in a project.
Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\crt\src\'...
Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\crt\src\vccorlib\'...
Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\atlmfc\src\mfc\'...
Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\atlmfc\src\atl\'...
Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\atlmfc\include'...
The debug source files settings for the active solution indicate that the debugger will not ask the user to find the file: c:\Sandboxes\ComponentSpace\SAMLv20\Library\Protocols\SAMLMessageSignature.cs.
The debugger could not locate the source file 'c:\Sandboxes\ComponentSpace\SAMLv20\Library\Protocols\SAMLMessageSignature.cs'.

So apparently the "original location" of c:\sandboxes\... is embedded in the DLL and it's looking there.  It is not finding anything, and it isn't getting any decompiled code from the dotPeek symbol server.  Anyone know why this might be?

Please sign in to leave a comment.