Bug with coverage highlighting in dotCover?

Hi all

I think I've found a bug in DotCover, and was wondering if anyone else has seen the same behaviour?

When reviewing coverage of my tests with highlighting turned on, a block of code will appear red when it is partially shown in the editor window (i.e. 1/2 a line is shown in red), but when I scroll down to bring it into completely view (i.e., a line or more is shown) it switches to green.

The correct colour is red, as I have not tested that code path.

This is when testing code written in the Rx framework, with lots of lambda methods, etc.

Has anyone else seen this issue? I've attached a screenshot showing the section of code showing this problem. There are 3 screenshots of the same section of code. Between each screen shot I have simpled scrolled down one unit.

Regards



Attachment(s):
broken-dotcover.JPG
3 comments
Comment actions Permalink

Hi Matt,
Thank you for the feedback.
Is this code located inside the lambda expression or anonymous delegate?

0
Comment actions Permalink

Hi

Yes, the whole try/catch clause is within a lambda, but it is only the code inside the catch block, and the catch block statement itself, that is not covered, and so sometimes shows up red and sometimes green.

I'm going to put together a sample solution showing this error and forward it to your support guys.


Regards
Matt

0
Comment actions Permalink

Thank you Matt!
Currently we are working on better highlighting and representation in coverage tree for the anonymous delegates and lambdas.

0

Please sign in to leave a comment.