Jump To Invalid Address when profiling application

I'm using Visual Studio 2008 SP1, without Resharper, and DotCover 1.1.224.17 on Windows 2008 R1 64-bit.

I use DotCover to launch mstest.exe as an application; I see it run all of the tests, watch them pass, and even publish the results to the TFS server. Once it does that, the mstest.exe window closes and is replaced with a message box titled DotCover 1.1, stating "[timestamp] Error: vstesthost.exe (6860): Jump To Invalid Address [OK]."

It then shows me the coverage dialog with 0% coverage.

If I run mstest.exe at the console with the same arguments, I do not get an error.

I'm using the DotCover EAP as I'm especially interested in the HTML reporting to be consumed by project leaders who don't have studio installed.

Is this a bug in DotCover, or should I be doing something differently?

3 comments

I got furtherby unchecking 'debug child processes'. However, it says I have 0% test coverage, even though I know I have tests that passed.

On a separate note, I'm performing this on a very large codebase. The resultant HTML file is 27 MB, and does not load in IE9 or Firefox 4; it may eventually but hasn't yet.  I suppose the HTML option is for small to medium codebases, and large codebases may be best served with custom reports on the XML?

0

THe 0% code coverage issue also occurs when I install DotCover 1.0.  As a final shot, I am going to install resharper to see if this is just an issue with covering an application (mstest.exe in this case).     

0

Hello John,
Please make sure that VS code coverage is disabled for your test configuration, this can be the source of the issue.
Regarding HTML reports: please try release version of dotCover from http://www.jetbrains.com/dotcover/
It contains certain reporting improvements compared to early EAP builds (like the one you have)

0

Please sign in to leave a comment.