Coverage failed with "Can't init profiler. PDB server wasn't started"

Hello,

I used dotCover v1.2 for some time without problems. So I updated my dotCover v1.2 with v2.1 on a VS2010.

Now I can't use dotCover anymore. When I start dotCover in a Unit Test session with NUnit test cases I always get the error message "Coverage analysis failed. (Can't initialize profiler. PDB server wasn't started. No snapshots created)".

Was something not installed correctly?

Wolfgang

3 comments

Hi Wolfgang,

This issue is fixed in the upcoming dotCover 2.2 release.
You are welcome to try the latest builds of dotCover 2.2 EAP: http://confluence.jetbrains.net/display/DCVR/dotCover+Early+Access+Program
Please let us know if you still experience this issue.

Regards.

0

Hello Fedor,

thx for the prompt answer.

I tried v2.2 Build 504 and now it works again! So I'm looking forward to the release of v2.2.

BTW: The filter dialog is much better than before in v1.x - yet overall I still have problems in understanding/handle the new dialog. Unfortunately the help link in the "Edit cov. filter" shows only an outdated description of filtering in v1.x.

Wolfgang

0

Hi Wolfgang,

Thank you for the feedback, I've opened a report in our bug-tracker about incorrect link: http://youtrack.jetbrains.com/issue/DCVR-4563
The actual info about coverage filters is available here: http://www.jetbrains.com/dotcover/webhelp/dotCover__Setting_up_Coverage_Filters.html

Regards.

0

Please sign in to leave a comment.