Problem or user error? Getting dotcover to analyse IIS Application

I am trying to run dotCover against an IIS application. The IIS application is running a c# 4.0 WCF service. I have a set of acceptance tests which run against IIS. I want to see how much code these tests cover.

I have the full version and latest (2.2.515.8) running in Visual Studio 2010 on windows 7 64 bit.

I have done the following:

1. Open dotCover -> Profile Start up application
The start up application window opens (IIS Application) and the correct url is set in the browser text box and the open browser checkbox is selected.
The Start profiling checkbox is checked

2. Click run
The dotCover controller window opens and all the buttons and drop downs are greyed out except 'Stop Service'

3. Try running tests or calling the web page from the browser
Nothing happens. If I do an iisreset, nothing happens. The process drop down is greyed out and empty.

If I close the dotCover Controller window, the message: Cover Analysis finished but no shapshot created box appears.

I get no report and I dont believe any analysis has taken place or in fact dotCover is attached to the IIS process at all.

I have tried various combinations of options, running the above sequence of steps when debugging and following the instructions given here:
http://www.jetbrains.com/dotcover/webhelp/dotCover_Manual__IIS.html

I have also tried uninstalling and re-installing dotCover but nothing seems to work

Any help much appreciated.

Thanks
Simon



Attachment(s):
dotcover-controller-greyout.png
2 comments

This was fixed magically by itself by doing the incredible technical solution of rebooting my machine. Seems to work now.

0

Hi Simon,

     Terribly sorry for the late reply.     
     I'm glad that it works fine for you now.

Regards.

0

Please sign in to leave a comment.