dotCover aborts the test run when running a my test in 64-bit process but completes when running in a 32-bit process

I have downloaded an evaluation copy of dotCover and ran into an issue that seems to be related to the fact that I want my tests to always run in a 64-bit process.

Configuration:

Windows 7 Professional 64-bit
Visual Studio 2012 Enterprise Edition
ReSharper 7.1.2 Build 7.1.2000.1478
dotCover 2.2 Build 2.2.515.8

ReSharper Unit Testing Configuration:
     MSTest
     Using a .testsettings file because I want the ReSharper test runner to run in a 64-bit process and ReSharper does not yet support VS 2012 runsettings files
     Use Legacy Runner option *not* enabled

I have a test that transforms an XML file using a large XSLT transform.

If I run the test using the ReSharper test runner (with the above configuration options) the test completes.
If I run the test with dotCover the test aborts with no information at all about what happened.

I can reproduce with a very simple test but before I submit this to the folks at JetBrains, I was wondering if anyone in the community has seen similar behavior.

Terri

Please sign in to leave a comment.