Testing coverage with dotCover and nunit from command line

I am running my unit and integration tests by using nunit and they are integrated into my CI environment (Jenkins). Now I am planning to integrate coverage inspection with dotCover into my environment as well. However there is now issue I do not understand and it is blocking me at the moment.

When I run dotCover analysis from command line with command dotCover analyse config_file, test report with xml is produced. However this result file only contains coverage from nunit test assembly dlls. There is no any coverage results from the assemblies containing the actual code. I am little confused.

When I run the same tests inside visual studio 2012 with R# by using dotCover, I can get coverage results from the assemblies as well. Is there some trick I am missing at the moment.

My analysis configuration file looks sismilar to https://www.jetbrains.com/dotcover/webhelp/Running_Coverage_Analysis_from_the_Command_LIne.html. I have replaces of course the paths to follow my environment.

What am I missing here? Thanks in advance.


Well, it seems that it depends whether you build debug or release. It would be great, if there would be some documentation about this issue.

Anyway, I can manage now by running the tests in debug mode ...


Hi Ilkka,

Thank you for contacting us.
It seems that your release build is done without PDB files, and dotCover needs the code to be built with PDBs.
Probably, it's should be more clearly pointed in our documentation.
Sorry for the inconvenience.




Missing pdb files was not the case here. Pdb files are generated. I assume that by default release build does not produce something that are required by dotCover. I agree with you that required msbuild settings should be documented and pointed out.


Please sign in to leave a comment.