Using the Command line just results in options dialog, and no profiling

I am trying to run the profiler from the command line using syntax such as the following, which results in the DotTrace options dialog being displayed:
"C:\Program Files\JetBrains\dotTrace 3.0\JetBrains.dotTrace.exe" -profile "C:\MyApp\Bin\Release\MyApp.exe"

I am running from a command prompt which has the current path set to the same as the application, e.g. "C:\MyApp\Bin\Release".

Any ideas why this isn't starting the application?

1 comment
Comment actions Permalink

To get the command line usage run:
jetBrains.dotTrace –h

There is a discrepancy between the command line parameters as presented in the dotTrace's help and the ones showed in the help dialog that pops up using the aforementioned command.
In your case, here is what your command line should look like:
jetBrains.dodTrace.exe –profile cpu –output C:\MyAppAnapshot.jbprof –application C:\MyApp\Bin\Release\MyApp.exe

You should be aware that, by default, the profiling mode is Tracing, and there is no way to specify the profiling mode (Tracing or Sampling) or the time profiling mode (Wall time or Thread Time). If there is a way to specify these options, is not documented.

Hope this helps.

Lucian

0

Please sign in to leave a comment.