Unit Testing with xUnit in dotTrace

Hi Folks,

with dotTrace 3.1 Unit Testing with xUnit was possible but returned false values, because there seemed to be a bug in xUnit with threading or something.
In dotTrace 4.0 Beta it is not even possible to profile xUnit Unit Tests.

To come to an ending what kind of Unit Frameworks are supported by dotTrace?
And why not xUnit?

Kind regards

3 comments

Hi Stephan,

Actually there are no problem to profile xUnit tests.
I have tried right now - with dotTrace version 4.0.566 (from night builds) - it works.

Here are some detalils:
First:
I just tried to run tests with command: xunit.console.exe C:\Projects\ConsoleApplication1\ConsoleApplication1xUnit\bin\Debug\ConsoleApplication1xUnit.dll /xml 1.xml
where:

  • C:\Projects\ConsoleApplication1\ConsoleApplication1xUnit\bin\Debug\ConsoleApplication1xUnit.dll is a path to dll with tests;
  • /xml 1.xml - is a parameter pointing where to store test results

Second:
I run the same but under dotTrace:
xUnit.JPG
Ok. And It works.

Here is step by step howto about using different unit test frameworks under dotTrace. I also added xUnit tips there.

0

Hi Ivan,

according to your answer and the wiki article I assume that it is not possible to profile an xUnit Test within VS2008 with Resharper 5.
But why?

0

Stephan,

We don't support xUnit out of the box, it's supported by third-party

plugin xUnitContrib. It should work well with dotTrace, although there

are some issues with dotCover, which are currently being resolved.

0

Please sign in to leave a comment.