SL4 & dotTrace 4 performance pro crashes because of System.ServiceModel not being present

Hello.
 
I am not sure if I missed something in the manuals, but dotTrace fails to profile my app entirely if I don't have System.ServiceModel referenced in my SL application and have it set to copy local true.
 
After attaching some debuggers I found that what happens is the application fails at App.InitializeComponent with a exception message that looks something like [Line:0 Pos:0], with one inner exception that complains about the fact that it cannot load System.ServiceModel because the strong name verification failed. This error might be related to my installation so here it is:
 
win7 SP1
vs2010 SP1
Installed SL5 beta stuffies (is this causing the problem?)
The SL app uses Ideablade's devforce, Caliburn.Micro and MEF extensively.
 
Another thing. vs2010 SP1 brings us iis express, but your stuff does not work with iis express. This is probably not a major problem because iis express crashes about as much as ASP.Net Development Server does, but are you going to support it in case? (In case because the entire VS2010 SL development IDE environment is a disaster. Microsoft really screwed this one up, but maybe they will fix it sometime)
 
One last thing. The default behaviour of dotTrace Performance is to profile the start-up application. In the case of silverlight, this is the web application and nobody is really interested in doing a trace on that. Can't you make it so that if there is a SL application loaded in the IDE that dotTrace starts and profiles the SL app instead of the "startup application". Its hellova annoying to type that shit in manually every time. I wan't to hit a button, and it must be so and I expect that from a addon that costs more than a operating system.



W
2 comments

Thank you for the questions.

Silverlight:
I have tried your setup Win7+VS2010SP1+SL5 w/o System.ServiceModel ref, but could not see the problem on the simple solution.
Could you please enable core logs and attach the results here?

IIS express support is planned for dotTrace 4.6 (next minor release from 4.5)
Currently it is possible to profile IIS express in .Net Process mode. That mode starts waits for any new dotNet processes and starts profiling them. Thus make sure to restarts IIS Express to have it profiled.

Regarding usability of profiling silverlight. Thats a problem. Thanks for the heads up.

Thanks.

0

Just wanted to let you know that I reproduced the issue (XP 64, VS2010SP1, dotTrace 4.0) and indeed setting CopyLocal to true fixed it.

Also, I want to chime in regarding poor usability of Silverlight profiling, it is quite an irritating issue.

0

Please sign in to leave a comment.