Profiling a web application under IIS

Hi, I'm evaluating dotTrace and I'm having some problems with profiling an ASP.NET application under IIS, I've followed the instructions outlined here:, but I've had no luck. Turning on logging produces these errors:

:57:54 PM.123: Thread:1: [GlobCleanUpUser] S-1-5-19 'C:\Windows\ServiceProfiles\LocalService\NTUser.dat' Failed
2:57:54 PM.123: Thread:1: [GlobCleanUpUser] S-1-5-20 'C:\Windows\ServiceProfiles\NetworkService\NTUser.dat' Failed
2:57:54 PM.268: Thread:1: [GlobCleanUpUser] S-1-5-21-3483202800-1294443289-788217339-4649 'C:\Users\***\NTUser.dat' Failed
2:57:54 PM.439: Thread:1: [GlobCleanUpUser] S-1-5-21-3876080227-1774565022-3202731406-1000 'C:\Users\***\NTUser.dat' Failed
2:57:54 PM.605: Thread:1: [GlobCleanUpUser] S-1-5-21-3999402647-1922055894-3561430602-19824 'C:\Users\***\NTUser.dat' Failed
2:57:54 PM.818: Thread:1: [GlobCleanUpUser] S-1-5-21-39997874-886523497-1299147156-122873 'C:\Users\***\NTUser.dat' Failed
2:57:55 PM.122: Thread:1: [GlobCleanUpUser] S-1-5-21-39997874-886523497-1299147156-123318 'C:\Users\***\NTUser.dat' Failed
2:57:55 PM.123: Thread:1: [GlobCleanUpUser] S-1-5-21-39997874-886523497-1299147156-131905 'C:\Users\***\NTUser.dat' Failed
2:57:55 PM.282: Thread:1: [GlobCleanUpUser] S-1-5-21-39997874-886523497-1299147156-64748 'C:\Users\***\NTUser.dat' Failed
2:57:55 PM.445: Thread:1: [GlobCleanUpUser] S-1-5-82-3006700770-424185619-1745488364-794895919-4004696415 'C:\Users\DefaultAppPool\NTUser.dat' Failed
2:57:55 PM.744: Thread:1: [GlobEnvUpdate]
2:58:45 PM.508: Thread:9: [SessionController] Finished
2:58:45 PM.520: Thread:10: [UserEnvClean]
2:58:45 PM.521: Thread:10: [GlobEnvClean]
2:58:45 PM.523: Thread:10: [GlobCleanUpUser] S-1-5-19 'C:\Windows\ServiceProfiles\LocalService\NTUser.dat' Failed
2:58:45 PM.524: Thread:10: [GlobCleanUpUser] S-1-5-20 'C:\Windows\ServiceProfiles\NetworkService\NTUser.dat' Failed
2:58:45 PM.685: Thread:10: [GlobCleanUpUser] S-1-5-21-3483202800-1294443289-788217339-4649 'C:\Users\***\NTUser.dat' Failed
2:58:45 PM.823: Thread:10: [GlobCleanUpUser] S-1-5-21-3876080227-1774565022-3202731406-1000 'C:\Users\***\NTUser.dat' Failed
2:58:45 PM.973: Thread:10: [GlobCleanUpUser] S-1-5-21-3999402647-1922055894-3561430602-19824 'C:\Users\***\NTUser.dat' Failed
2:58:46 PM.155: Thread:10: [GlobCleanUpUser] S-1-5-21-39997874-886523497-1299147156-122873 'C:\Users\***\NTUser.dat' Failed
2:58:46 PM.464: Thread:10: [GlobCleanUpUser] S-1-5-21-39997874-886523497-1299147156-123318 'C:\Users\***\NTUser.dat' Failed
2:58:46 PM.465: Thread:10: [GlobCleanUpUser] S-1-5-21-39997874-886523497-1299147156-131905 'C:\Users\***\NTUser.dat' Failed
2:58:46 PM.609: Thread:10: [GlobCleanUpUser] S-1-5-21-39997874-886523497-1299147156-64748 'C:\Users\***\NTUser.dat' Failed
2:58:46 PM.790: Thread:10: [GlobCleanUpUser] S-1-5-82-3006700770-424185619-1745488364-794895919-4004696415 'C:\Users\DefaultAppPool\NTUser.dat' Failed

I'm running the tests in Visual Studio and the DotTrace controller window only has the option to stop the application, which doesn't work when clicked. I will try to provide any additional information that is requested.


Hello Brad,
Please try the following:
1. run dotTrace (and also remote agent, if you're profiling remotely) as administrator;
2. reduce the amount of logged-in users on your machine to as little as possible. The best variant is only one user :)
Please let me know if it doesn't help.


Thanks for the response. Unfortunately your fix did not help, but my problem was not very clear. It turned out that the problem rooted from ASP.NET not being enabled in Windows features(Control Panel -> Programs and Features -> Turn Windows features on or off -> Internet Information Services\World Wide Web Services\Application Development Features\ASP.NET enabled), among other things specific to my web.config file. I've got it figured out now and maybe someone else will make the same mistake as me in thinking that ASP.NET is enabled by default with IIS, so I'll mark it as solved. Thanks again.



Brad, I've written an email to you before checking the forum :) Thanks for letting me know that the problem is solved, and glad to hear it works now.


Please sign in to leave a comment.