Cannot open an old non-exported workspace

I do not want to reopen a 3-year-old topic, but I do have the same problem as … 

inside the dotmemory UI, I do have Settings\Workspace location set to d:\dotmemory, so if I launch a new profiling session, it will be created as d:\dotmemory\workspaces\XXXXXX (I tested this, and a new folder shows up there when I start a new profiling) … 

so I copied all the old profiling session data into d:\dotmemory\workspaces\Qazonod (it contains everything: ProfilingData folder, state folder, workspace.idx file) , and the old workspace is still not listed inside the “Workspaces” list inside dotmemoryUI …

How can I open this unexported workspace only with copying the old files? (dotmemoryUI 2023.3.1)


I don't recommend you to do that!

But if you look at the contents of the file '%USERPROFILE%\AppData\Local\JetBrains\Shared\vAny\dotMemory\workspace.list' and change the paths to the workspace file in it, it might work.

Don't forget to back up this file before any manipulation!



Thanks, I managed to open the workspace this way.

(I created a new quick profiling session, this new profiling session was present in the workspace.list file ... Then I simply edited the new entry in the list file so that it no longer points to the quick profiling session's path - now it referenced the desired old existing workspace's path. It worked like a charm :) )


Please sign in to leave a comment.