Unable to import .net 7 Azure Web App dump into DotMemory

I am using a premium linux app service plan in Azure.  I took a memory dump and attempted to load it into dotMemory and received the following error:


I find it hard to believe there's a compatibility issue here.  Does anyone know why we’re seeing [CLR#1 Core 0.0]?  I'm assuming it's simply throwing the error because it thinks the dotnet version is 0 for some reason.



Could you please provide us with additional info?
First of all, please collect dotMemory logs:

  • Clear %temp%\JetLogs folder.
  • Go to dotMemory installation folder: %localappdata%\JetBrains\Installations\dotMemory[N]
  • Using the Windows command line start a product with arguments: dotMemory.UI.64.exe /LogLevel=Trace
  • Try to import a process dump, wait for the error.
  • Attach all logs from the %temp%\JetLogs folder: JetBrains Uploads
    Could you please also install dotnet-dump and dotnet-symbol utility to the same machine where you run dotMemory and perform these commands:
  • dotnet-symbol <Path to .dmp>
  • dotnet-dump analyze <Path to .dmp>
  • Wait for the message:
Ready to process analysis commands. Type 'help' to list available commands or 'help [command]' to get detailed help on a command.
Type 'quit' or 'exit' to exit the session.
  • Execute dumpheap -stat command

Does dumpheap -stat command return any result? If any error occurs, could you please send error text? 


Hey, I have the exact same problem with a dump collected using dotnet-dump running in a linux environment.

when i run dotnet-dump analyze on my windows workstation, and dumpheap -stat it works as expected.

I uploaded my logs
Upload id: 2023_10_26_e23ANmwmpfre5Wbz6VFTQN (file: JetBrainsLog.JetBrains.2023-10-26T10-56-56.dotMemory_UI_64.zip)


Do you use proxy to connect to the internet on this computer?


On my laptop (which i ran dotMemory on) my traffic is routed through an anti-virus esque security agent, so yes technically.
The server, from where I got the dump, no.

I can reupload from a machine without the “proxy” if needed


Could you please try to do this? We have some assumptions that the issue could be related to proxy.


I tried it on 3 different machines now.
2 of them without the “proxy”/anti-virus, it worked perfectly
 - Upload id: 2023_10_27_XGGtf19s3KaDVkRWRvzPPY (file: JetLogs_1.zip)
 - Upload id: 2023_10_27_JcuStw7BZE3ahCvUwqD6kv (file: JetLogs.zip)
the 1 with the proxy did get this error.

So I agree, it seems likely that's the issue


Thank you for information.

We're working on a fix.


Please sign in to leave a comment.