Code editor loses focus when dotcover runs dirty tests

Answered

I have setup dirty test discovery and running on save, using visual studio build. Unfortunately, when I press ctrl+s, VS sets focus on Error list window.

This means that if I want to continue typing I have tab around or click to continue typing.

I tried using Resharper build, it helped, but this option had it's own problems.

4 comments

Hello Justinas

Do you mean VS Error list window? Or maybe VS Output window?

Then disabling Options -> Projects and Solutions -> Show Output window when build starts setting in VS options should help you.

0

It's the Error List window that gets the focus:

I tried different combinations of option you suggested and "Always show Error List..." option in the same tab. The only difference is when "Show Output window" is enabled, focus jumps to Output window instead of error list. I couldn't find any other options to disable Error list.

0

So far I'm resorting on running builds manually instead of using dotCover. I hope it get's fixed in future releases or I miraculously manage to find what's causing the problem in Visual Studio.

0

Hello, Justinas

Unfortunately, we can't reproduce the problem on our side.

Could you please us with the exact R# and VS versions which you use? Also, it would be very helpful if you create a video screencast (you may use free tool http://www.techsmith.com/jing.html) which will demonstrate the issue.

Thank you.

 

0

Please sign in to leave a comment.