All tests marked as dirty on save

Completed

I am having an issue where dotCover marks all tests as dirty in my continuous testing session regardless of if any code was changed. I can save a file without making any changes, and all tests are still marked dirty. I am on version 2017.1.3. I have tried clearing R# caches, reverting to version 2017.1.2, uninstalling and reinstalling dotCover, and restarting the computer. This is not happening on my co-worker's installation. What am I missing? Here are the Trace level logs from the Continuous Testing Session when I save.

 

2017.08.08 14:20:37.955 INFO BuildStage started
2017.08.08 14:20:37.955 INFO Build policy: Never
2017.08.08 14:20:38.096 INFO 0 projects built
2017.08.08 14:20:38.096 INFO BuildStage completed
2017.08.08 14:20:38.096 INFO RefreshProjectPropertiesStage started
2017.08.08 14:20:38.228 INFO RefreshProjectPropertiesStage completed
2017.08.08 14:20:38.228 INFO DiscoveryStage started
2017.08.08 14:20:38.364 INFO Test exploration required for 0 projects
2017.08.08 14:20:38.364 INFO DiscoveryStage completed
2017.08.08 14:20:38.364 INFO BuildPipelineStage started
2017.08.08 14:20:38.364 INFO BuildPipelineStage completed
2017.08.08 14:20:38.364 INFO ApplyRulesStage started
2017.08.08 14:20:38.640 INFO Got 869 elements (0 explicit) to run
2017.08.08 14:20:38.640 INFO Marking 869 elements as Pending
2017.08.08 14:20:38.715 INFO Marking elements as Pending completed
2017.08.08 14:20:38.715 INFO Distributing 869 elements into runs
2017.08.08 14:20:38.716 INFO Host Controller initialization started
2017.08.08 14:20:38.717 VERBOSE Host Controller: ContinuousTestingHostController
2017.08.08 14:20:38.717 INFO Host Controller initialization completed
2017.08.08 14:20:38.729 INFO Distributing elements completed
2017.08.08 14:20:38.729 INFO Created 4 unit-test runs
2017.08.08 14:20:38.729 INFO ApplyRulesStage completed
2017.08.08 14:20:38.729 INFO RunTestsStage started
2017.08.08 14:20:38.743 VERBOSE Running up to 8 unit-test runs in parallel
2017.08.08 14:20:38.743 INFO Run: 2caec203-79ed-40b5-b75e-e4bbec43c884 - Started
2017.08.08 14:20:38.743 VERBOSE Provider: MSTest
Project: Application.Tests
Target Framework: .NETFramework,Version=v4.6.1
Strategy: JetBrains.ReSharper.UnitTestProvider.MSTest11.MsTestOutOfProcessUnitTestRunStrategy
Runtime Enviroment:
Platform Type: x86
Platform Version: v4_5
2017.08.08 14:20:38.743 INFO Run: a30972ab-6111-4a65-a5a6-9e171e39c55f - Started
2017.08.08 14:20:38.743 VERBOSE Provider: MSTest
Project: Infrastructure.Tests
Target Framework: .NETFramework,Version=v4.6.1
Strategy: JetBrains.ReSharper.UnitTestProvider.MSTest11.MsTestOutOfProcessUnitTestRunStrategy
Runtime Enviroment:
Platform Type: x86
Platform Version: v4_5
2017.08.08 14:20:38.743 INFO Run: c145cf55-f442-4887-ab58-efce12d65c7c - Started
2017.08.08 14:20:38.743 VERBOSE Provider: MSTest
Project: Presentation.Api.Tests
Target Framework: .NETFramework,Version=v4.6.1
Strategy: JetBrains.ReSharper.UnitTestProvider.MSTest11.MsTestOutOfProcessUnitTestRunStrategy
Runtime Enviroment:
Platform Type: x86
Platform Version: v4_5
2017.08.08 14:20:38.743 INFO Run: ba390f17-a4f6-41ea-830a-3552a8400e98 - Started
2017.08.08 14:20:38.743 VERBOSE Provider: MSTest
Project: Presentation.Web.Tests
Target Framework: .NETFramework,Version=v4.6.1
Strategy: JetBrains.ReSharper.UnitTestProvider.MSTest11.MsTestOutOfProcessUnitTestRunStrategy
Runtime Enviroment:
Platform Type: x86
Platform Version: v4_5
2017.08.08 14:20:44.588 INFO Run: 2caec203-79ed-40b5-b75e-e4bbec43c884 - Completed
2017.08.08 14:20:46.257 INFO Run: c145cf55-f442-4887-ab58-efce12d65c7c - Completed
2017.08.08 14:20:47.173 INFO Run: a30972ab-6111-4a65-a5a6-9e171e39c55f - Completed
2017.08.08 14:20:50.461 INFO Run: ba390f17-a4f6-41ea-830a-3552a8400e98 - Completed
2017.08.08 14:20:50.461 INFO RunTestsStage completed
2017.08.08 14:20:52.083 INFO Finishing run
2017.08.08 14:20:52.090 INFO Run is finished

2 comments

Hello,

Could you please try to drop continuous testing results (please see the screenshot)?

If it doesn't help, could you please enable ReSharper logging, reproduce the issue and send us log files? In order to enable logging please start Visual Studio with the following command line arguments:

devenv.exe /ReSharper.LogLevel Verbose /ReSharper.LogFile

Log files will be saved in the '%Temp%\JetLogs' folder with auto-generated names, so empty this folder before you launch VS.

0

Hi Ekaterina,

 

Using the Drop Results button fixed the issue. Thank you for your help!

0

Please sign in to leave a comment.