dotMemory.exe has lost connection with the process JetBrains.dotMemory.ExternalProcessor.exe

Symptom

After you run a profiling session, dotMemory shows the error window "dotMemory.exe has lost connection with the process JetBrains.dotMemory.ExternalProcessor.exe...".

Possible reasons

  • Antivirus software loads a DLL into the JetBrains.dotMemory.ExternalProcessor.exe process and prevents it from normal operation.

Check whether antivirus is a problem

Using Windows command-line run the following command:
"<dotMemory installation path>\JetBrains.dotMemory.ExternalProcessor.exe" -name=test

(for dotMemory 4.1 and earlier the command is: JetBrains.dotMemory.ExternalProcessor.exe test)

If you get the following error message  “Unhandled Exception: System.IO.FileLoadException: Mixed mode assembly is built against version 'v2.0.50727' of the runtime and cannot be loaded in the 4.0 runtime without additional configuration information.”, then antivirus software loads a DLL into the JetBrains.dotMemory.ExternalProcessor.exe process and prevents it from normal operation.
If you don’t get the message shown above, then probably, antivirus is not a problem.

Solution

1. Open the JetBrains.dotMemory.ExternalProcessor.exe.config file located in the <dotMemory installation path> folder.

2. Replace the line:

<startup>

with the following one:

<startup useLegacyV2RuntimeActivationPolicy="true">

Alternatively, you can replace the configuration file with the one attached to this post.

  • Firewall software prohibits named pipes communication.

Solution

Allow named pipes communication in your firewall so that dotMemory.exe and JetBrains.dotMemory.ExternalProcessor.exe processes can communicate with each other.

  • Something in your environment prohibits "Create Global Objects" action for unprivileged user account.

Solution

Control Panel\All Control Panel Items\Administrative Tools\Local Security Policy\Local Policies\User Rights Assignment, allow "Create Global Objects" policy, restart computer.

 

2 comments

Aapo Saaristo, dotMemory works if you run it with administrator privileges but doesn't work if you run it under unprivileged user account. It's an issue: https://youtrack.jetbrains.com/issue/DMRY-2747
"Create Global Objects" policy should help in this case.

0

I have disabled both my Anti-Virus and my Firewall, but this problem still persists. dotTrace works without issue, and I'm completely out of ideas on what to try next.

0

Please sign in to leave a comment.

Have more questions?

Submit a request